FileUp
Topic: Re: AXFile Error

SoftArtisans Forums

Page 1 of 1 (5 items)


Posted by nopower on 10-04-2011 2:51 PM

Windows 7 32 bit
IE 8

FileUp shows this Error once the progress indicator window pops up.

AXFile Error
ERROR: Source = SoftArtiSans.XRequest.1
Description = null

Please help.


Posted by AlisonB on 10-24-2011 2:33 PM

Hello nopower,

Is there anything in your machine's event logs that might have a bit more detail?

Are you using one of our samples?
If not, would it be possible to post a bit of your code?

When you are trying to perform the file transfer, are you logged in as an administrator or standard user?

What version of XFile are you using?
You can find the version of XFile from several places:

1. In IE, under Tools > Manage Add-ons. From the drop-down select "All add-ons." You should see SoftArtisans XFile under the list of add-ons. If you select the add-on, in the details area should be the version (e.g. 2.5.2.21304).

2. On the file transfer page, in the source should be the <object> tag under the "codebase" attribute. The number will be seperated by commas instead of periods (e.g. "2,5,1,1222").

Regards,
Alison


Posted by nopower1 on 10-25-2011 3:06 PM

 AlisonB wrote:

Hello nopower,

Is there anything in your machine's event logs that might have a bit more detail?

Nothing out of the ordinary listed.

 AlisonB wrote:

Are you using one of our samples?
If not, would it be possible to post a bit of your code?

I am not sure how to answer this question.

 AlisonB wrote:

When you are trying to perform the file transfer, are you logged in as an administrator or standard user?

The error occurs when logged in as either.

 AlisonB wrote:

What version of XFile are you using?
You can find the version of XFile from several places:

1. In IE, under Tools > Manage Add-ons. From the drop-down select "All add-ons." You should see SoftArtisans XFile under the list of add-ons. If you select the add-on, in the details area should be the version (e.g. 2.5.2.21304).

2. On the file transfer page, in the source should be the <object> tag under the "codebase" attribute. The number will be seperated by commas instead of periods (e.g. "2,5,1,1222").

Version: 2,1,7,20333


Posted by nopower1 on 10-25-2011 3:22 PM
I have noticed a pattern that his seems to only occur on Windows 7 machines (both 32 and 64 bit) Running Internet Explorer 8.

Posted by AlisonB on 10-27-2011 9:28 AM

Hello nopower,

I believe you are running into an issue that happens with older versions of XFile where the real error message is masked by the "error=null description=null" message. This issue was fixed in version 2.3.4.

There is a workaround for this issue, which is to check the XFRequest.ResponseStatus property to find the real error message.

In general, your version of XFile (2.1.7) is a very old version of XFile. I would recommend upgrading to the latest version (2.5.3) because there have been numerous fixes made to the product since your version. This includes the ATL security vulnerabilities (more more info, see Microsoft Security Bulletin MS09-035), which were addressed in v2.5.0.

Regards,
Alison